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Introduction to Polyspace Code Prover

• “Polyspace Code Prover Product Description” on page 1-2
• “Getting Help” on page 1-3
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Polyspace Code Prover Product Description
Prove the absence of run-time errors in software

Polyspace Code Prover™ proves the absence of overflow, divide-by-zero, out-of-bounds
array access, and certain other run-time errors in C and C++ source code. It produces
results without requiring program execution, code instrumentation, or test cases.
Polyspace Code Prover uses static analysis and abstract interpretation based on formal
methods. You can use it on handwritten code, generated code, or a combination of the
two. Each operation is color-coded to indicate whether it is free of run-time errors, proven
to fail, unreachable, or unproven.

Polyspace Code Prover also displays range information for variables and function return
values, and can prove which variables exceed specified range limits. Results can be
published to a dashboard to track quality metrics and ensure conformance with software
quality objectives. Polyspace Code Prover can be integrated into build systems for
automated verification.

Support for industry standards is available through IEC Certification Kit (for IEC 61508
and ISO 26262) and DO Qualification Kit (for DO-178).

Key Features

• Proven absence of certain run-time errors in C and C++ code
• Color-coding of run-time errors directly in code
• Calculation of range information for variables and function return values
• Identification of variables that exceed specified range limits
• Quality metrics for tracking conformance with software quality objectives
• Web-based dashboard providing code metrics and quality status
• Guided review-checking process for classifying results and run-time error status
• Graphical display of variable reads and writes
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Getting Help

In this section...

“Access Documentation” on page 1-3
“Access Contextual Help” on page 1-3

Polyspace provides documentation and contextual help describing workflows, tasks,
concepts, analysis options, checks, and functions.

Access Documentation

The full documentation is available in the Polyspace interface and its plug-ins. To access
the documentation:

• Polyspace interface — Select Help > Help.
• Simulink® plug-in — Select Code > Polyspace > Help.
• Eclipse™ plug-in — Select Polyspace > Help.
• Visual Studio® add-in — select Polyspace > Help.
• IBM® Rational® Rhapsody® plug-in — Right-click on a package. From the context

menu, select Polyspace. In the Polyspace Verification dialog, select Help.

Access Contextual Help

To access contextual help for analysis options in the Polyspace interface or a Polyspace
plug-in:

1 In the Configuration pane, hover your cursor over an analysis option.
2 In the tooltip, select More Help.
3 Look in the Contextual Help pane to see more help for that option.

To access contextual help for Polyspace results from the Polyspace interface:

1 In the Results Summary pane, select a Polyspace check.
2

In the Result Details pane, select .
3 Look in the Contextual Help pane to see more help for that check.
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Related Examples
• “Configure Polyspace Analysis Options and Properties”
• “Configure Polyspace Verification”
• Configure File and Default Options in Visual Studio
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Set Up a Polyspace Project
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Set Up Polyspace Project

In this section...

“Tutorial Overview” on page 2-2
“What Is a Project?” on page 2-2
“Prepare Project Folder” on page 2-2
“Open Polyspace Code Prover” on page 2-4
“Create Project” on page 2-4
“Next steps” on page 2-6

Tutorial Overview

In this tutorial, you create a new Polyspace Code Prover project to verify C code.

What Is a Project?

A Polyspace project consists of:

• Source files.
• Include folders.
• One or more modules. You run verification on the source files in each module. Each

module has the following folders:

• Source — Contains files used for verification.
• Configuration — Contains analysis options used for verification.
• Result — Contains results of verification.

Prepare Project Folder

In the following procedures, MATLAB_Install is the MATLAB® installation folder, for
instance, C:\Program Files\MATLAB\R2015b.

1 Create a folder polyspace_project in a particular location, for example C:\.
2 Open polyspace_project and create subfolders:



 Set Up Polyspace Project

2-3

• sources

• includes

3 Copy example.c from MATLAB_Install\polyspace\examples\cxx
\Demo_C_Single-File\sources to polyspace_project\sources.

4 Copy include.h from MATLAB_Install\polyspace\examples\cxx
\Demo_C_Single-File\sources to polyspace_project\includes.
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Open Polyspace Code Prover

• Open directly in your operating system.

• Windows®: From the MATLAB_Install\polyspace\bin folder, double-click the
polyspace-code-prover executable.

You can create a desktop or Start menu shortcut to this executable with the icon

if it does not already exist.
• Linux® or Mac: Run the following command:

/MATLAB_Install/polyspace/bin/polyspace-code-prover

• Open from MATLAB.

From the MATLAB Apps gallery, click the Polyspace Code Prover app.

Create Project

• “Create New Project” on page 2-4
• “Specify Source Files and Include Folders” on page 2-6

Create New Project

1 Select File > New Project.
2 In the Project – Properties dialog box:

• For Project name, enter example_project.
• Clear the Use default location check box. To specify where your

polyspace_project folder is, click .
• For Project language, select C.
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• Clear the boxes under Project Configuration. For more information on the
option Use template, see “Create Project Using Template”. For more information
on the option Create from build command, see “Create Project Automatically”.

3 Click Next.
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Specify Source Files and Include Folders

1 Select the sources folder that you created. Click Add Source Files.
2 Select the includes folder. Click Add Include Folders

Note: Polyspace Code Prover automatically adds standard header files to your
project.

3 Click Finish. You can see your project in the Project Browser.

Next steps

1 “Run Verification” on page 4-2
2 “Review Results” on page 5-2
3 “Find Coding Rule Violations” on page 6-2

Related Examples
• “Create Project”
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Server Configuration for Remote
Verification and Polyspace Metrics

• “Set Up Polyspace Metrics” on page 3-2
• “Set Up Server for Metrics and Remote Analysis” on page 3-8
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Set Up Polyspace Metrics

In this section...

“Requirements for Polyspace Metrics” on page 3-2
“Start Polyspace Metrics Server” on page 3-3
“Configure Polyspace Preference” on page 3-4
“Configure Web Server for HTTPS” on page 3-5
“Change Web Server Port Number for Metrics Server” on page 3-6

Requirements for Polyspace Metrics

You can use Polyspace Metrics to:

• Store verification and analysis results.
• Evaluate and monitor software quality metrics.

The following table lists the requirements for Polyspace Metrics.

Task Location Requirements

Project configuration
and uploads to
server

Client
node

• MATLAB
• Polyspace Bug Finder™ or Polyspace Code Prover

Polyspace Metrics
service

Network
server
or head
node of
MATLAB
Distributed
Computing
Server™
cluster

• MATLAB
• Polyspace Bug Finder

Activation is not required for the Polyspace Metrics
service

Downloading
complete results from
Polyspace Metrics

Client
node or a
network
computer

• MATLAB
• Polyspace Bug Finder or Polyspace Code Prover
• Access to Polyspace Metrics server



 Set Up Polyspace Metrics

3-3

Task Location Requirements

Viewing results
summary from
Polyspace Metrics

A network
computer

Access to Polyspace Metrics server.

You cannot merge two different Polyspace metrics databases. However, if you install a
newer version of Polyspace on top of an older version, Polyspace Metrics automatically
updates the database to the newest version.

Start Polyspace Metrics Server

This task shows you how to start the host server for Polyspace Metrics. You must also
configure the client-side settings so that the Polyspace interface can interact with the
Metrics server.

Note: If you are using a Mac as your Polyspace Metrics server, when you restart the
machine you must restart the Polyspace server daemon.

1 From the Polyspace environment, select Metrics > Metrics and Remote Server
Settings.

2 Under Polyspace Metrics Settings, specify:

• User name used to start the service — Your user name.
• Password — Your password (Windows only).
• Communication port — Polyspace communication port number (default 12427).

This number must be the same as the communication port number specified in
the Polyspace Interface preferences. See “Configure Polyspace Preference” on
page 3-4.

• Folder where analysis data will be stored — Results repository for Polyspace
Metrics server.

3 If you have installed MATLAB Distributed Computing Server, clear the Start the
Polyspace mdce service without security level check box.

For information about starting your remote cluster service, see “Set Up Server for
Metrics and Remote Analysis” on page 3-8.

4 To start the Polyspace Metrics server, click Start Daemon.
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The software stores the information that you specify through the Metrics and Remote
Server Settings window in the following file:

• On a Windows system, \%APPDATA%\PolyspaceRLDatas\polyspace.conf
• On a Linux system,  /etc/Polyspace/polyspace.conf

Configure Polyspace Preference

Once you have set up your Polyspace metrics server, you must set the client-side settings
so that the Polyspace interface can communicate with your Metrics server.

1 Select Tools > Preferences.
2 Click the Server Configuration tab.
3 Under the Polyspace Metrics server configuration section:

a If you want Polyspace to detect a server on the network that uses port 12427
(default port number), click Automatically detect the Polyspace Metrics
Server.

b If you use a different port number for your Metrics server or you want to specify
the server name, click Use the following server and port. Fill in your server
name or IP address, and communication port number.

You must specify the same communication port number for all clients that use
the Polyspace Metrics service.

4 Under the Polyspace Metrics web interface configuration section:

a Specify a Port used to download results, default is 12428. If you change this
port number, you must also change it in on the server side.

b Specify which protocol to use HTTP or HTTPS. If you select HTTPS for your web
protocol, there are additional steps to set up the Metrics web server for HTTPS.

c Specify a web server port number for your chosen protocol. Default port numbers
are:

• HTTP — 8080
• HTTPS — 8443

If you change the port number from the default, you must configure the same
port number for the Polyspace Metrics server. See “Change Web Server Port
Number for Metrics Server” on page 3-6.
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5 Under the Upload and download settings section:

• Upload settings — After you review results from the Metrics repository, you can
upload your comments and justifications back to the repository using Metrics >
Upload to Metrics.

If you want Polyspace to automatically upload your justifications to Polyspace
Metrics when you save, select Upload justifications automatically in the
Polyspace Metrics repository....

• Download settings — In Polyspace Metrics, when you click an item to view,
Polyspace downloads your results and opens them in the Polyspace environment.
Select where to download your Polyspace Metrics results, either:

• To the project folder, or, if none exists, a default folder.
• Ask every time where to download results.

To view Polyspace Metrics, in the address bar of your web browser, enter:

protocol://ServerName:WSPN

• protocol is http or https.
• ServerName is the name or IP address of your Polyspace Metrics server.
• WSPN is the web server port number, the default is 8080 or 8443.

Configure Web Server for HTTPS

By default, the data transfer between Polyspace Code Prover and the Polyspace Metrics
web interface is not encrypted. You can enable HTTPS for the web protocol, which
encrypts the data transfer. To set up HTTPS, you must change the server configuration
and set up a keystore for the HTTPS certificate.

Before you start the following procedure, you must complete “Start Polyspace Metrics
Server” on page 3-3 and “Configure Polyspace Preference” on page 3-4.

To configure HTTPS access to Polyspace Metrics:

1 Open the Metrics and Remote Server Settings dialog box. Run the following
command:

MATLAB_Install\polyspace\bin\polyspace-server-settings.exe
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2 Click Stop Daemon. The software stops the mdce and Polyspace Metrics services.
Now, you can make the changes required for HTTPS.

3 Open the %APPDATA%\Polyspace_RLDatas\tomcat\conf\server.xml file in a
text editor. Look for the following text:

<!-

  <Connector port="8443" SSLEnabled="true" scheme="https" 

  secure="true" clientAuth="false" sslProtocol="TLS" 

  keystoreFile="<datadir>/.keystore" keystorePass="polyspace"/>

->

If the text is not in your server.xml file:

a Delete the entire ..\conf\ folder.
b In the Metrics and Remote Server Settings dialog box, restart the daemon by

clicking Start Daemon.
c Click Stop Daemon to stop the services again so that you can finish setting up

the server for HTTPS.

The conf folder is regenerated, including the server.xml file. The file now contains
the text required to configure the HTTPS web server.

4 Follow the commented-out instructions in server.xml to create a keystore for the
HTTPS certificate.

5 In the Metrics and Remote Server Settings dialog box, to restart the Polyspace
Metrics service with the changes, click Start Daemon.

To view Polyspace Metrics, in the address bar of your web browser, enter:

https://ServerName:WSPN

• ServerName is the name or IP address of the Polyspace Metrics server.
• WSPN is the web server port number.

Change Web Server Port Number for Metrics Server

If you change or specify a non-default value for the web server port number of your
Polyspace Code Prover client, you must manually configure the same value for your
Polyspace Metrics server.

1 Select Metrics > Metrics and Remote Server Settings.
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2 In the Metrics and Remote Server Settings dialog box, select Stop Daemon to stop
the Polyspace Metrics server daemon.

3 In AppData\Polyspace_RLDatas\tomcat\conf\server.xml, edit the port
attribute of the Connector element for your web server protocol.

• For HTTP:

<Connector port="8080"/> 

• For HTTPS:

  <Connector port="8443" SSLEnabled="true" scheme="https" 

  secure="true" clientAuth="false" sslProtocol="TLS" 

  keystoreFile="<datadir>/.keystore" keystorePass="polyspace"/>

4 In the Metrics and Remote Server Settings dialog box, select Start Daemon to
restart the server with the new port number.

5 On the Polyspace toolbar, select Tools > Preferences.
6 In the Server Configuration tab, change the Web server port number to match

your new value.

Related Examples
• “Generate Code Quality Metrics”
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Set Up Server for Metrics and Remote Analysis

In this section...

“Requirements for Remote Verification and Analysis” on page 3-9
“Start Server for Remote Verification and Polyspace Metrics” on page 3-9
“Configure Polyspace Preferences” on page 3-10

You can run the following types of verification and analyses.

Analysis type Run when

Remote batch Source files are large (more than 800 lines of code including
comments), and execution time of verification is long.

Local Source files are small, and execution time of verification is short.

You can also use Polyspace Metrics with your remote verifications, but it is not required.
For more information about setting up Polyspace Metrics, see “Set Up Polyspace Metrics”
on page 3-2.

The following figure shows a network that consists of a MATLAB Distributed Computing
Server cluster and a Parallel Computing Toolbox™ client. Polyspace Code Prover and
Polyspace Bug Finder are installed on the head node and client nodes.

To set up remote verification:
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1 Configure the head node with the Metrics and Remote Server Settings dialog box.
See, “Start Server for Remote Verification and Polyspace Metrics” on page 3-9.

2 Configure the client node through the Polyspace environment preferences. See,
“Configure Polyspace Preferences” on page 3-10.

Requirements for Remote Verification and Analysis

The following table lists the requirements for remote verification.

Task Location Requirements

Project configuration
and job submission

Client
node

• MATLAB
• Parallel Computing Toolbox
• Polyspace Bug Finder or Polyspace Code Prover

Remote analysis and
verification

Head node
of cluster

• MATLAB Distributed Computing Server
• Polyspace Bug Finder
• Polyspace Code Prover

For information about setting up a computer cluster, see “Install Products and Choose
Cluster Configuration”.

Start Server for Remote Verification and Polyspace Metrics

This procedure describes how to set up an MATLAB Distributed Computing Server
head node that is also the Polyspace Metrics server. If you do not want to set up
Polyspace Metrics, use the MATLAB Distributed Computing Server Admin Center to
set up a server for your remote verifications. See “Install Products and Choose Cluster
Configuration”.

1 Select Metrics > Metrics and Remote Server Settings.
2 Under Polyspace Metrics Settings, specify:

• User name used to start the service — Your user name.
• Password — Your password (Windows only).
• Communication port — Polyspace communication port number (default 12427).

This number must be the same as the communication port number specified on
the Polyspace Preferences > Server Configuration tab.
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• Folder where analysis data will be stored — Results repository for Polyspace
Metrics server.

3 To configure the Polyspace Metrics server as the MATLAB Distributed Computing
Server head node, select Start the Polyspace mdce service without security
level.

The mdce service, which is required to manage the MJS, runs on the MJS host
computer with security level 0. At level 0, jobs are associated with the default user
name of the user. No login or password is required to manage and see these jobs.

If you want to require authentication to use the remote server, use the MATLAB
Distributed Computing Server Admin Center. For more information about setting
up security levels, see “Set MJS Cluster Security”.

Under Start the Polyspace mdce service without security level, you see the
following additional options:

• Mdce service port — 27350.

This option specifies the port on which you connect to the MJS server. If you
change this number, you must change it on both the server and client side. See
“Verify Network Communications for Cluster Discovery”.

• Use secure communication – Not selected by default

By default, communication between the job manager and workers is not
encrypted. To make the connection more secure, you can select this option to
encrypt communications. Alternatively, you can also increase the security level of
your MJS server, see “Set MJS Cluster Security”.

4 To start the Polyspace Metrics server and mdce service, click Start Daemon.

The software stores the information that you specify through the Metrics and Remote
Server Settings dialog box in the following file:

• On a Windows system, %APPDATA%\PolyspaceRLDatas\polyspace.conf
• On a Linux system, /etc/Polyspace/polyspace.conf

Configure Polyspace Preferences

1 Select Tools > Preferences.
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2 Click the Server Configuration tab.
3 Under MATLAB Distributed Computing Server cluster configuration:

a In the Job scheduler host name field, specify the computer for the head node
of the cluster. This computer hosts the MATLAB job scheduler (MJS).

b If you specified localhost as the job scheduler host name, enter the localhost
IP address in the Localhost IP address field.

You can configure additional options for the MJS host through the MATLAB
Distributed Computing Server Admin Center. See “Configure for an MJS”.

4 Under the Polyspace Metrics server configuration section:

a If you want Polyspace to detect a server on the network that uses port 12427
(default port number), click Automatically detect the Polyspace Metrics
Server.

b If you use a different port number for your Metrics server or you want to specify
the server name, click Use the following server and port. Fill in your server
name or IP address, and communication port number.

You must specify the same communication port number for all clients that use
the Polyspace Metrics service.

5 Under the Polyspace Metrics web interface configuration section:

a Specify a Port used to download results, default is 12428. If you change this
port number, you must also change it in on the server side.

b Specify which protocol to use HTTP or HTTPS. If you select HTTPS for your web
protocol, there are additional steps to set up the Metrics web server for HTTPS.

c Specify a web server port number for your chosen protocol. Default port numbers
are:

• HTTP — 8080
• HTTPS — 8443

If you change the port number from the default, you must configure the same
port number for the Polyspace Metrics server. See “Change Web Server Port
Number for Metrics Server” on page 3-6.

6 Under the Upload and download settings section:
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• Upload settings — After you review results from the Metrics repository, you can
upload your comments and justifications back to the repository using Metrics >
Upload to Metrics.

If you want Polyspace to automatically upload your justifications to Polyspace
Metrics when you save, select Upload justifications automatically in the
Polyspace Metrics repository....

• Download settings — In Polyspace Metrics, when you click an item to view,
Polyspace downloads your results and opens them in the Polyspace environment.
Select where to download your Polyspace Metrics results, either:

• To the project folder, or, if none exists, a default folder.
• Ask every time where to download results.

Related Examples
• “Set Up Polyspace Metrics” on page 3-2
• “Run Remote Verification”
• “Run File-by-File Remote Verification”
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Run Verification

In this section...

“Tutorial Overview” on page 4-2
“Before You Start the Tutorial” on page 4-2
“Prepare for Verification” on page 4-2
“Run Remote Verification” on page 4-3
“Run Local Verification” on page 4-4
“Next steps” on page 4-5

Tutorial Overview

In this tutorial, you run verification on your source code. Perform the steps outlined for
remote verification if you want to perform verification on another machine. Otherwise,
perform the steps outlined for local verification.

Before You Start the Tutorial

Before you start, you must:

• Complete “Set Up Polyspace Project” on page 2-2. You use the polyspace_project
folder and the example_project.psprj file in this tutorial.

• “Set Up Server for Metrics and Remote Analysis” on page 3-8 for remote verification
and “Set Up Polyspace Metrics” on page 3-2 for Polyspace Metrics.

Prepare for Verification

If example_project.psprj is not already open in the Project Browser, then:

1 Select File > Open.
2 In the Open File dialog box, navigate to polyspace_project.
3 Select the project file example_project.
4 Click Open.
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Run Remote Verification

• “Start Verification” on page 4-3
• “Monitor Progress” on page 4-3
• “Stop Verification” on page 4-4

Start Verification

Before you start remote verification, you must perform a one-time setup. See “Set Up
Server for Metrics and Remote Analysis” on page 3-8.

1 On the Project Browser pane, select the configurationexample_project in
Module_1.

2 On the Configuration pane, select Distributed Computing.
3 Select Batch and Add to results repository.
4

On the toolbar, click .

The following happens:

a On the local host computer, Polyspace Code Prover compiles your code.
b The Parallel Computing Toolbox then submits the verification to the MATLAB

Job Scheduler on the head node of the MATLAB Distributed Computing Server
cluster.

For more information, see “Phases of Verification”.

Note: If you see the message Verification process failed, click OK. For more
information on troubleshooting remote verification errors, see “Polyspace Cannot Find
the Server”.

Monitor Progress

To monitor the progress of a remote verification:

1 Select Tools > Open Job Monitor.
2 In the Polyspace Job Monitor, right-click your verification.
3 Select View Log File.
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Stop Verification

To stop a remote verification:

1 Select Tools > Open Job Monitor.
2 In the Polyspace Job Monitor, right-click your verification.
3 Select Remove From Queue.

Run Local Verification

• “Start Verification” on page 4-4
• “Monitor Progress” on page 4-4
• “Stop Verification” on page 4-5

Start Verification

To start a verification on your local computer:

1 In the Project Browser, select the configuration example_project in Module_1.
2 On the Configuration pane, select Distributed Computing. Clear Batch if it is

selected.
3

On the toolbar, click .

If the verification fails, see “Troubleshooting in Polyspace Code Prover”.

Monitor Progress

To monitor the progress of a local verification, on the Output Summary pane, use the
following tabs:

• Output Summary
• Run Log

If this window is not visible by default, select Window > Show/Hide View > Run
Log.

When the verification is complete, you see:

• Results on the Results Summary pane.
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• Statistics, such as Code covered by verification and Check Distribution on the
Dashboard pane.

Stop Verification

To stop a local verification:

1
On the toolbar, click .

A warning dialog box opens.
2 Click Yes.

The verification stops. If you restart the verification, it starts from the beginning.

Next steps

1 “Review Results” on page 5-2
2 “Find Coding Rule Violations” on page 6-2

Related Examples
• “Run Verification”
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Review Results

In this section...

“Tutorial Overview” on page 5-2
“Open Results” on page 5-2
“Review Results” on page 5-3
“Generate Report” on page 5-5
“Next steps” on page 5-5

Tutorial Overview

In this tutorial, you explore the results of verifying example.c. Before starting this
tutorial, complete “Run Verification” on page 4-2.

Open Results

• “Remote Verification” on page 5-2
• “Local Verification” on page 5-2

Remote Verification

To open results from a remote verification:

1 Select Metrics > Open Metrics.

Alternatively, you can enter the remote address directly in a web browser. For more
information, see “View Polyspace Metrics Project Index”.

2 Click the Project cell of your verification.

You can see a summary of your project.
3 On the Summary tab, click the 1.0 cell in the Verification column.

Your results are downloaded into the user interface.

Local Verification

After verification, the results open automatically.
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Review Results

Polyspace performs checks on each operation in your code. The software reports whether
a check is green, red, orange or gray.

Check color Indicates

Red The code operation fails the check on every
execution path.

Green The code operation passes the check on
every execution path.

Orange The code operation fails the check on some
execution paths.

Gray The code operation is unreachable from
entry-point functions.

1 On the Results Summary pane, select Group by > File.

The checks are grouped by file. Within each file, the checks are grouped by function.
2 Expand the following function names and select a check in the function. The

corresponding line of code on the Source pane appears highlighted. Further
information about the check appears on the Result Details pane.

Function Check Source Code
Appearance

Reason

Unreachable_CodeGray Unreachable
code

The code within
braces starting from
line 193 is gray.

x is greater than 0.
So the if statement
branch cannot be
reached.

Square_Root Red Invalid use of
standard library
routine

The function sqrt
on line 178 is red.

beta is less
than 0.75. So the
argument to sqrt
is always negative.

Non_Infinite_LoopFirst green
Overflow

The + sign on line
73 is green.

When y is too large,
the while loop
terminates. So the
operation x=x+2
never overflows.
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Function Check Source Code
Appearance

Reason

Recursion Orange Division
by Zero

The / sign on line
132 is orange.

*depth can be
less than zero.
Therefore, at
some level in the
recursion, the
denominator can be
zero.

3 To find further information about a check, do one of the following:

• Place your cursor on the check in the Source pane. View the tooltip.

Use the variable range information in the tooltips to trace the data flow.
•

Click the  button on the Result Details pane. You can see a brief description
of the check type, code examples and additional guidance on how to review that
check type.

4 Filter Illegally dereferenced pointer checks. To do this, on the Results
Summary pane:

a
Click  on the Check column header.

b From the drop-down list, clear All and select Illegally dereferenced pointer.

The Results Summary pane displays only the Illegally dereferenced pointer
checks.

5 On the Results Summary pane, select the red Illegally dereferenced pointer
check in the function Pointer_Arithmetic. Enter the following review
information.

Column Action

Severity High

Status Fix

Comment p points outside array
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Generate Report

To generate a verification report:

1 If your verification results are not already open, open them.
2 Select Reporting > Run Report.

3 In the Select Reports section, select Developer.
4 For Output folder, select C:\polyspace_project

\Module_1\Result_1\Polyspace-Doc.
5 For Output format, select PDF .
6 Click Run Report.

The software creates the specified report and opens it.

Next steps

“Find Coding Rule Violations” on page 6-2
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Related Examples
• “Review Results”
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Find Coding Rule Violations

In this section...

“Tutorial Overview” on page 6-2
“Specify MISRA C Checking” on page 6-2
“Review MISRA C Violations” on page 6-3

Tutorial Overview

In this tutorial, you analyze code to demonstrate compliance with established coding
standards such as MISRA C 2004.

Using these rules during coding:

• Helps reduce amount of unproven code in your verification results.
• Improves the quality of your code.

Before you start, you must “Set Up Polyspace Project” on page 2-2.

Specify MISRA C Checking

To set the MISRA C checking option:

1 On the Project Browser, select the configuration example_project in Module_1.
2 On the Configuration pane, select Coding Rules & Code Metrics. Select Check

MISRA C:2004.
3 From the corresponding drop-down list, select custom.
4 Click Edit. The New File dialog box opens, displaying a table of rules.
5 In the New File dialog box, specify the rules to check.

a Clear the MISRA C:2004 rules check box.
b Select the check boxes for the following rules.

Rule Number Rule description

16.3 Identifiers shall be given for all of the
parameters in a function prototype
declaration.
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Rule Number Rule description

17.4 Array indexing shall be the only
allowed form of pointer arithmetic.

Click OK to save the file.
6

On the toolbar, click  .

After verification and coding rules checking, the results open automatically. If you
have previous results on the Results Summary pane, you are prompted whether
you want to open your new results. Click OK.

You can open your previous results from the Project Browser pane.

Review MISRA C Violations

To examine the MISRA C violations:

1 On the Results Summary pane, select Group by > Family.

The MISRA C:2004 violations appear as a separate group.
2 Expand the nodes and select a coding-rule violation. You see the following.
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Pane Result

Source The line containing the rule violation is
highlighted.

Result Details The following information is displayed:

• Description of violated rule.
• File and function where the rule

violation appears.

Click the  button. You can see a
rationale for the rule. For certain rules,
you can see additional code examples
displaying violations of the rule.

3 On the Source pane, right-click the highlighted code. Select Open Editor.

The example.c file opens on the Code Editor tab. You can also use an external
text editor. Select Tools > Preferences and specify an external editor on the
Editors tab.

4 Fix the MISRA® violation and rerun the verification. The coding rule violation no
longer appears in the results.

Related Examples
• “Check Coding Rules”
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• “Verification of Code Generated from Simulink Models” on page 7-2
• “Verify Code from a Simple Simulink Model” on page 7-3
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Verification of Code Generated from Simulink Models

With Embedded Coder® or dSPACE® TargetLink® software, you can generate code from
Simulink models. From Simulink, you can use Polyspace Code Prover to verify the
generated code. The software detects run-time errors in the generated code and helps you
to locate and fix model faults.

Use the following approach:

1 Configure your Simulink model and generate code. See  .
2 Configure Polyspace verification options. See “Polyspace Configuration for Generated

Code”

Note: After generating code, you can run a verification without manual
configuration. By default, Polyspace Code Prover automatically creates a project and
extracts required information from your model. However, you can also customize
your verification. See “Configure Polyspace Analysis Options and Properties”.

3 Run Polyspace verification. See:

• “Run Analysis for Embedded Coder”
• “Run Analysis for TargetLink”

4 View results, analyze errors, locate and fix model faults. See “View Results in
Polyspace Code Prover”.

The software allows direct navigation from a run-time error in the generated code
to the corresponding Simulink block or Stateflow® chart in the Simulink model. See
“Identify Errors in Simulink Models”.
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Verify Code from a Simple Simulink Model

In this section...

“Create Simulink Model and Generate Code” on page 7-3
“Run Polyspace Verification” on page 7-6
“View Results in Polyspace Code Prover” on page 7-6
“Trace Error to Simulink Model” on page 7-7
“Specify Signal Ranges” on page 7-9
“Verify Updated Model” on page 7-12

Create Simulink Model and Generate Code

To create a simple Simulink model and generate code:

1 Open MATLAB. Then start Simulink software.
2 Construct the following model.

3 Select File > Save. Then name the model my_first_model.
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4 Select Tools > Model Explorer. The Model Explorer opens.
5 From the Model Hierarchy tree, expand the node my_first_model. Select

Configuration.

6 Select the Configuration for Code Generation. Specify the following code
generation options. Click Apply to save your options.

Tab Group Option User Action

General Target selection System target file Enter ert.tlc for
Embedded Coder.

Create code-
generation report

Select the box.Report  

Code-to-model Select the box.
Templates Custom templates Generate an

example main
program

Clear the box.

Interface Code interface Suppress error
status in real-
time model data
structure

Select the box.
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7 Select the Configuration for Solver. Specify the following solver options. Click
Apply to save your options.

Group Option User Action

Solver options Type Select  Fixed-step.
Solver options Solver Select discrete (no

continuous states).

8 Select the Configuration for Optimization. Specify the following optimization
options. Click Apply to save your options.

Tab Group Option User Action

Remove root
level I/O zero
initialization

Select the box.General Data
initialization

Use memset to
initialize floats
and doubles to 0.0

Clear the box.

Signals and
Parameters

Code generation Default
parameter
behavior

Select Inlined.

9 To generate code, from the Simulink model window, select Code > C/C++ Code >
Build Model.
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Run Polyspace Verification

1 From the Simulink model window, select Code > Polyspace > Verify Code
Generated for > Model.

The verification starts, and you see messages in the MATLAB Command Window.

### Starting Polyspace verification for Embedded Coder

### Creating results folder results_my_first_model for system my_first_model

### Parameters used for code verification:

 System                : my_first_model

 Results Folder        : C:\results_my_first_model

 Additional Files      : 0

 Verifier settings     : PrjConfig

 DRS input mode        : DesignMinMax

 DRS parameter mode    : None

 DRS output mode       : None

 Model Reference Depth : Current model only

 Model by Model        : 0

...

2 Follow the progress of the verification in the MATLAB Command window.

Note: Verification of this model takes about a minute. A 3,000 block model will take
approximately one hour to verify, or about 15 minutes for each 2,000 lines of generated
code.

View Results in Polyspace Code Prover

When the verification is complete, you can view the results using the Polyspace Code
Prover interface.

1 From the Simulink model window, select Code > Polyspace  > Open Results.

After a few seconds, Polyspace Code Prover opens.
2 On the Results Summary pane, select Group by > None.
3 Select the orange Overflow check.

The Result Details pane shows information about the orange check, and the
Source pane shows the source code containing the orange check.
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This orange check shows a potential overflow issue when multiplying the signals
from the inports In1 and In2. Polyspace considers that the signal values are full
range. So multiplying the two signals can result in an overflow.

Trace Error to Simulink Model

To fix this overflow issue, you must return to the Simulink model.

To trace the error to your model:

1 Click the blue underlined link (<Root>/Product) immediately before the check in
the Source pane. The Simulink model opens, highlighting the block with the error.

2 Examine the model. The highlighted block multiplies two full-range signals, which
could result in an overflow.

The verification has identified a potential bug. This could be a flaw in:

• Design — If the model should be robust for the full signal range, then the issue is a
design flaw. In this case, you must change the model to accommodate the full signal
range. For example, you could saturate the output of the previous block, or bound the
signal with a Switch block.
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• Specifications — If the model is supposed to work for specific input ranges, you
can provide these ranges using block parameters or the base workspace. The next
verification will read these ranges from the model, and the check will be green.
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Specify Signal Ranges

If you constrain the input signals in your Simulink model, Polyspace verifies the
generated code for these inputs. The Overflow check is green in the verification results.

To specify signal ranges using source block parameters:

1 Double-click the In1 source block in your model. The Source Block Parameters
dialog box opens.

2 Select the Signal Attributes tab.
3 Set the Minimum value for the signal to -15.
4 Set the Maximum value for the signal to 15.
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5 Click OK.
6 Using above steps, set the minimum values for the In2 block to -15 and maximum

value to 15.
7 Save your model as my_first_model_bounded.
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Verify Updated Model

After changing the model, you must regenerate code and run verification again.

To regenerate code and rerun the verification:

1 From the Simulink model, select Code > C/C++ Code > Build Model.

The software generates code for the updated model.
2 Select Code > Polyspace > Verify Code Generated for > Model.

The software verifies the generated code.
3 Select Code > Polyspace  > Open Results, which opens Polyspace Code Prover.

The Overflow check is now green. Polyspace verification shows that the generated
code does not have run-time errors.
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Verify Code in IBM Rational Rhapsody Environment

In this section...

“Code Verification Approach” on page 8-2
“Adding Polyspace Profile to Model” on page 8-3
“Accessing Polyspace Features” on page 8-3
“Configuring Verification Options” on page 8-6
“Running a Verification” on page 8-7
“Viewing Polyspace Results” on page 8-7
“Locating Faulty Code in Rhapsody Model” on page 8-8
“Template Configuration Files” on page 8-9

Code Verification Approach

In a collaborative Model-Driven Development (MDD) environment, software run-time
errors can be produced by either design issues in the model or faulty handwritten code.
You may be able to detect the flaws using code reviews and intensive testing. However,
these techniques are time-consuming and expensive.

With Polyspace Code Prover, you can verify C, C++ and Ada code that you generate from
your IBM Rational Rhapsody model. As a result, you can detect run-time errors and
automatically identify model flaws quickly and early during the design process.

For information about installing and using IBM Rational Rhapsody, go to
www-01.ibm.com/software/awdtools/rhapsody/.

The approach for using Polyspace Code Prover within the IBM Rational Rhapsody MDD
environment is:

• Integrate the Polyspace add-in with your Rhapsody project. See “Adding Polyspace
Profile to Model” on page 8-3.

• If required, specify Polyspace configuration options in the Polyspace verification
environment. See “Configuring Verification Options” on page 8-6.

• Specify the include path to your operating system (environment) header files and
run verification. See “Running a Verification” on page 8-7.

http://www-01.ibm.com/software/awdtools/rhapsody/
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• View results, analyze errors, and locate faulty code within model. See “Viewing
Polyspace Results” on page 8-7 and “Locating Faulty Code in Rhapsody Model”
on page 8-8.

Adding Polyspace Profile to Model

Before you try to access Polyspace features, you must add the Polyspace profile to your
model.

Note: You cannot submit local batch verifications with Polyspace for Rhapsody (for
example, using local Parallel Computing Toolbox workers). If you want to submit
local batch verifications, use the Polyspace environment or the MATLAB command,
polyspaceCodeProver.

1 In the Rhapsody editor, select File > Add Profile to Model. The Add Profile to
Model dialog box opens.

2 Navigate to the folder MATLAB_Install\polyspace\plugin\rhapsody
\profiles\Polyspace.

3 Select the file Polyspace.sbs. Then click Open.

Now, if you right-click a package or file, you see the Polyspace item in the context
menu. Selecting Polyspace opens the Polyspace Verification dialog box.

Accessing Polyspace Features

To access Polyspace features in the Rhapsody editor:

1 Open the model that you want to verify. For example,
psdemos_uml_link_airbag.rpy in MATLAB_Install/polyspace/plugin/
rhapsody/psdemos.
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2 In the Entire Model View, expand the Packages node.
3 Right-click a package, for example, AirBagFiles.
4 From the context menu, select Polyspace.

The Polyspace Verification dialog box opens.
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Through the Polyspace Verification dialog box, you can:

• Specify verification options. See “Configuring Verification Options” on page 8-6.
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• Start a verification. See “Running a Verification” on page 8-7.
• Stop a local verification. See “Running a Verification” on page 8-7.
• View verification results. See “Viewing Polyspace Results” on page 8-7.
• Open help.
• Open the Polyspace Job Monitor. See “Running a Verification” on page 8-7.

Configuring Verification Options

To specify options for your verification:

1 In the Entire Model View, right-click a package or class, for example,
AirbagControl.

2 From the context menu, select Polyspace.
3 In the Polyspace Verification dialog box, click Configure. The Configuration pane

of the Polyspace verification environment opens.
4 Select options for your verification. In particular, you must specify the following:

• Target & Compiler > Target operating system (-OS-target)
• Target & Compiler > Dialect  (-dialect)
• Target & Compiler > Environment Settings >  Include (-include) — Path

to your operating system (environment) header files.
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• Distributed Computing >  Batch (-include) — For local verification, clear
the check box. For remote verification, select the check box.

5 To save your options, on the toolbar, click .

For information on how to choose your options, see:

• “Analysis Options for C Code”
• “Analysis Options for C++ Code”

Running a Verification

Before starting a verification, make sure that the generated code for the model is up to
date.

To start a verification:

1 In the Rhapsody editor, select Tools > Polyspace. The Polyspace Verification dialog
box opens.

2 In the Results folder field, specify a location for your verification results.
3 Select the Verification mode. Click Class or File. If you click Class, from the

Class to verify drop-down list, select a specific class. In addition, under Verify
with (highlight classes), you can select other classes from the displayed list.

4 If you want to run the analysis on your Polyspace server, select Send to Polyspace
server.

Note: If you are performing local batch verification with Polyspace for Rhapsody,
MATLAB Distributed Computing Server, and Parallel Computing Toolbox, you
can only submit local batch analyses from the Polyspace environment or using the
command.

5 Click Run. In the Log view of the Rhapsody editor, you see verification messages.

If your verification is local, you can observe progress in the Log view of the Rhapsody
editor. To stop the local verification, in the Polyspace Verification dialog box, click Stop.

To stop or monitor a batch verification, use the Job Monitor.

Viewing Polyspace Results

To view results from the last local verification:
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1 In the Rhapsody editor, select Tools > Polyspace.
2 In the Polyspace Verification dialog box, click Open Results.

The software displays results in the Polyspace user interface.

To view results from remote verifications, use Polyspace Metrics or the Job Monitor.

For more information, see “Review Results”.

Declarations for C Functions Without Arguments

By default, Rhapsody generates declarations for functions without parameters, using the
form:

void my_function()

rather than:

void my_function(void)

This can result in the following Polyspace compilation error:

Fatal error: function 'my_function' has unknown prototype.

To avoid this problem, in Rhapsody, at the project level, set the property
C_CG::Configuration::EmptyArgumentListName to void.

Locating Faulty Code in Rhapsody Model

To identify the faulty code within your Rhapsody model using Polyspace verification
results:

1 In your verification results, navigate to an error.
2 In the Source pane, right-click the error. From the context menu, select Back To

Model.

Tip For the Back To Model command to work, you must have your Rhapsody model
open.

The Back To Model command works best when the Polyspace check is enclosed by
the tags //#[ and ]#//.
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The software locates the faulty code within your Rhapsody model. Depending on the
Rhapsody configuration, the faulty code appears either in a dialog box or in the code
view.

The 64-bit version of the Polyspace product supports the Back To Model command
only for version 8.0 of the IBM Rational Rhapsody product. For other versions, use
the 32-bit Polyspace version.

To install the 32-bit Polyspace version, from a DOS command window, run the
following command:

DVD\Installer32bits\Windows\Disk1\InstData\VM\Polyspace.exe

Template Configuration Files

• “Using Template Configuration Files” on page 8-9
• “Default Configuration Options” on page 8-10

Using Template Configuration Files

The first time you perform a verification, the software copies a template, Polyspace
configuration file, from Polyspace_Install/polyspace/plugin/rhapsody/etc/
template_language.psprj to the project folder. The software also renames the copy
model_language.psprj, where:

• model is the name of your model.
• language is the name of the language that the model targets, that is, C or C++.

You can update the template .psprj file by one of the following means:

• Editing it through the Polyspace verification environment
• Double-clicking the file in a Windows Explorer window
• Replacing the template file with a copy of the .psprj file from a Rhapsody model

folder

You can then share a configuration among project members and use the configuration
with other projects.
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Default Configuration Options

The template_language.psprj XML files specify the default option values for code
verification.

The file template_C.psprj is:
<?xml version="1.0" encoding="UTF-8"?>

<polyspace_project name="template_psprj" language="C" author="polyspace" 

version="1.0" date="08/04/2011" path="file:/C:/Polyspace/Polyspace_Common

/Rhapsody/PolyspaceUMLLink/etc/template_C.psprj">

  <source>

  </source>

  <include>

  </include>

  <module name="Verification_1" isactive="true">

    <source>

    </source>

    <optionset name="template_psprj" isactive="true">

      <option flagname="-OS-target">no-predefined-OS</option>

      <option flagname="-respect-types-in-fields">true</option>

      <option flagname="-respect-types-in-globals">true</option>

    </optionset>

  </module>

</polyspace_project>

The file template_C++.psprj is:
<?xml version="1.0" encoding="UTF-8"?>

<polyspace_project name="template_psprj" language="C++" author="polyspace" 

version="1.0" date="08/04/2011" path="file:/C:/Polyspace/Polyspace_Common

/Rhapsody/PolyspaceUMLLink/etc/template_C++.psprj">

  <source>

  </source>

  <include>

  </include>

  <module name="Verification_1" isactive="true">

    <source>

    </source>

    <optionset name="template_psprj" isactive="true">

      <option flagname="-D">[OM_NO_FRAMEWORK_MEMORY_MANAGER]</option>

      <option flagname="-OS-target">no-predefined-OS</option>

      <option flagname="-dialect">gnu</option>

      <option flagname="-respect-types-in-fields">true</option>

      <option flagname="-respect-types-in-globals">true</option>

      <option flagname="-target">i386</option>

    </optionset>

  </module>

</polyspace_project>


